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1. Introduction
The purpose of the Label Editor is to simplify the process of creating and managing the label
formats used in Ishida weighing and label printing equipment. The main Label Editor features
are as follows.

•  Provides a visual interface for creating and editing labels.

•  Label format data can be sent to and read from the scales via a serial port.

•  The structure of the label format data in the Label Editor can be modified to take
account of future scales upgrades.

System Requirements

Label Editor requires a Windows 3.1 or higher personal computer with a free serial port.
(The FDP-5010 and Astra versions require Windows 95 or higher.)

Installing Label Editor

1. Startup Windows, then run SETUP.EXE from the installation floppy disk. Follow the
instructions that appear on the screen.

2. Double click on the Label Editor icon to run Label Editor.

3. Select Comms Setup from the Setup menu and check that the communication
parameters are set correctly for your PC.

For a quick summary of how to use Label Editor, see Getting Started.

Uninstalling Label Editor

Click the Uninstall icon in the Label Editor group to remove Label Editor from your hard disk.

How to Use This Manual

If you are a new user wishing to familiarize
yourself with the software.

ð See Chapter 2  Getting Started

If you wish to learn how to use a specific
feature.

ð Lookup the feature in the Contents and
find the relevant chapter.

If you require information about the
operation of a particular menu or other
command.

ð Refer to On-Line Help (click Index in the
Help menu.)
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2. Getting Started
This section describes some simple steps to get you started with creating and editing labels.
The section also introduces the main concepts used in the Label Editor program.

WARNING:  The Label Editor setup must match the scales exactly. If not, labels may not print
correctly and the scales may malfunction. Do not change the setup unless you
are thoroughly familiar with the requirements of the scales.
Also, a label data file saved for a particular setup will not work correctly if loaded
when the setup is different. The Label Editor checks the validity of label data
files on opening and displays error messages if the contents do not match the
setup.

Starting Label Editor
When you start the Label Editor, the program automatically loads the default setup data and
opens a new, empty Label List window. The Label List window consists of a list containing
the number of label slots that can be stored on the scales. Double-clicking on a slot opens a
Label Edit window for the label in that slot, or for a new label if the slot is empty.
After starting the program you can perform one of the following operations to start editing a
label.

Receive label data from the scales
If the computer is connected to a set of scales, you can download the label formats from the
scales. See the explanation below.
Downloading existing formats from the scales is particularly useful if you do not know the
correct address and other scale-specific parameters in the Label Properties dialog.

Open an existing label data file
Select Open from the File menu and open an existing label file. Example label files are
provided with the Label Editor.

Create a new label
Double click on an empty slot in the Label List window to open a Label Edit window for a new
label.

Receiving Label Data from the Scales
The operation differs depending upon which version of the Label Editor you are using:

AC-3000
If this is the first time you have run the Label Editor, select Comms Setup from the Setup
menu and check that the communication parameters are set correctly. Also check that the
cable to the scales is plugged into the specified serial port.

1. Select Receive File from the Tools menu. A File Open dialog appears for you to specify
the file in which to save the formats.

2. A Comms Progress dialog box appears to display the status of the data transfer. Wait for
the dialog box to appear, then initiate data transfer from the scales.

3. After transfer has completed, a message box appears asking whether you wish to import
the received data into a label data file. (The message box does not appear if you
transmitted data other than label formats.) Select "Yes". A new Label List window opens
containing the label formats received from the scales.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.
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FDP-5010
If this is the first time you have run the Label Editor, select Comms Setup from the Setup
menu and check that the communication parameters are set correctly. Also check that the
cable to the scales is plugged into the specified serial port.

1. Select Communicate with Scales from the Tools menu. A dialog opens asking whether
you wish to save the currently open label file in IF21 format. You must save the file if you
wish to send it to the scales. If you click "Yes", a File Open dialog appears for you to
specify the file name.
For this tutorial, click "No".

2. A dialog opens for you to specify the directory containing the scales data. The Data Save
(IF21) communications function on the scales was initially intended for use with a
dedicated floppy disk backup unit (called an IF21FD). When communicating with a PC,
this directory fills the role of the floppy disk on the IF21FD.
For this tutorial, simply click OK to use the default directory.

3. A Comms Progress dialog box appears to display the status of the data transfer. Wait for
the dialog box to appear, then initiate data transfer from the scales.
The progress dialog displays the number of bytes sent and received.

4. When you have finished the data transfer, click the Close button in the progress dialog to
end the communications session.

5. If a label data file was received during the communications session, a message box
appears asking whether you wish to import the received data into a label data file. Select
"Yes". A new Label List window opens containing the label formats received from the
scales.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

Astra
If this is the first time you have run the Label Editor, select Comms Setup from the Setup
menu and check that the communication parameters are set correctly. Also check that the
cable to the scales is plugged into the specified serial port.

1. Select Receive from Scales from the Tools menu.

2. A dialog opens with instructions on how to initiate data transfer from the scale.
Follow the instructions to start the transfer.

3. Once data transfer starts, the dialog displays progress.

4. When data transfer is complete, a new dialog opens asking you what to do with the
received data. Select "Load into new database" to create a new database with the
received scale data.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

Opening a Label Edit Window
To edit an existing label, double click on the label in the Label List window (or select the label
and press Enter). This opens a Label Edit window for the label.
Similarly, double-clicking on an empty slot in the Label List window creates a new label format
and opens the format in a Label Edit window.
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Editing Print Fields
The left side of the Label Edit window contains the Insert buttons. Cursor mode is selected
when the Label Edit window first opens, as indicated by the cursor button (the top button)
appearing depressed. In cursor mode, you can use the mouse or TAB key to select fields in
the label.
Editing operations that can be performed on a selected field include dragging and resizing,
opening a properties dialog to edit the print field's properties (by double-clicking on the field),
and the standard Windows cut, copy and paste operations.
See Editing Label Formats for a full description of how to edit print fields.

Inserting Print Fields

1. Click an insert button other than the cursor button. This sets the Label Edit window to
insert mode. The selected insert button specifies the unit type of the print field to insert.

2. Drag with the mouse to specify where to insert the new print field.

3. If more than one print ID has the specified unit type, a menu opens for you to select the
print ID for the field.

4. Next, an Edit Properties dialog appears for you to edit the properties for the field. Make
any required changes, then click OK. The new print field appears at the specified location
on the label and the window returns to cursor mode.

See Editing Label Formats for a full description of inserting print fields.

Displaying Sub-Labels
Each label field can be assigned to a number of sub-labels (in the Edit Properties dialog).
Use the View menu or the buttons at the righthand end of the toolbar to select which sub-
label to edit.

Transmitting Label Data to the Scales
The operation differs depending upon which version of the Label Editor you are using:

AC-3000

1. Make the Label Edit window for the label you wish to transmit the active window, or select
the label in the Label List window

2. Select Transmit Label from the Tools menu and wait for the Comms Progress dialog box
to appear, then initiate data transfer from the scales.

3. A message box appears to notify you when transmission of the label data has completed.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

FDP-5010

1. Make the Label Edit window for the label you wish to transmit the active window, or select
the label in the Label List window

2. Select Communicate with Scales from the Tools menu. A dialog opens asking whether
you wish to save the currently open label file in IF21 format. You must save the file if you
wish to send it to the scales. If you click "Yes", a File Open dialog appears for you to
specify the file name.
For this tutorial, click "No".
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3. A dialog opens for you to specify the directory containing the scales data. The Data Save
(IF21) communications function on the scales was initially intended for use with a
dedicated floppy disk backup unit (called an IF21FD). When communicating with a PC,
this directory fills the role of the floppy disk on the IF21FD.
For this tutorial, simply click OK to use the default directory.

4. A Comms Progress dialog box appears to display the status of the data transfer. Wait for
the dialog box to appear, then initiate data transfer from the scales.
The progress dialog displays the number of bytes sent and received.

5. When you have finished the data transfer, click the Close button in the progress dialog to
end the communications session.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

Astra

1. Make the Label Edit window for the label you wish to transmit the active window, or select
the label in the Label List window

2. Select Send to Scales -> Current Label Only from the Tools menu.

3. A dialog opens with instructions on how to initiate data transfer from the scale.
Follow the instructions to start the transfer.

4. A message box appears to notify you when transmission of the label data has completed.

See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.
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3. Creating and Managing Labels
This section describes how to create new labels and manage the label data.
The following lists the main label creation and edit operations.

Managing Label Data
A label data file stores the label formats for one set of scales. Opening a label data file opens
a Label List window which displays a list of label slots. Empty label slots are marked
"Unused".
You can use the Label List window to copy and paste labels between slots (and between
label data files), and to open Label Edit windows or Label Properties dialogs for specific
labels.
Use the File menu to open, close, and save label data files.

Receiving Label Data from the Scales
You can download the existing label formats from the scales. It is often easier to download
and modify existing label formats than to create new labels from scratch.
See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

Saving Label Data in an EPROM File
Select Import Labels from the File menu to import labels from an EPROM file. To use this
feature, the EPROM offset address must be set correctly in the setup.

Importing Label Data from a Binary Format File
Select Import Labels from the File menu to import binary format labels.

Exporting Label Data to a Binary Format File
Select Export Labels from the File menu to save labels to a binary format label file.

Exporting Label Data to an EPROM File
Select Save to EPROM File from the File menu to save the contents of the current data file
to an EPROM file. Both binary and Intel Hex formats are supported for the EPROM file.
To use this feature, the EPROM offset address must be set correctly in the setup.

Creating a New Label
Double click on an unused slot in the Label List window (or select the slot and press Enter).
This creates a new label and adds the default print fields. A Label Properties dialog opens for
you to set the label parameters such as the label size and product name area type. Clicking
OK saves the settings and opens a Label Edit window for you to edit the new label.

Transmitting Label Data to the Scales
See Sending and Receiving Labels from the Scales for a full description of how to transmit
and receive label data from the scales.

Editing Label Properties
Select a label in the Label List window then select Edit Properties from the Edit menu to edit
the label's properties.
The Label Properties dialog edits properties specific to an entire label (rather than to specific
print fields).
You can also open the Label Properties dialog from the Label Edit window by double clicking
on a point in the label that does not contain a print field.
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Editing Label Formats
Editing Label Formats describes in detail how to edit label formats using the Label Edit
window.
To open a Label Edit window for a label, double click on the label in the Label List window (or
select the label and press Enter).

Outputting a List of Label Contents
You can use the Dump Label to Text File command in the tools menu to output a list of the
label fields to a text file. This lists the coordinates of each label field. (The X, Y coordinates
are for the bottom left of the field and the origin is the bottom left of the label.)
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4. Editing Label Formats
This section describes how to edit labels in the Label Edit window.
The following edit operations can be performed on labels in the Label Edit window.

NOTE: The Product Name and Store Name and Address fields have a special meaning in
Ishida labels. Consequently, certain restrictions apply when editing these fields. See,
Some Background on Ishida Label Formats.

Select a Print Field
Click on a print field to select it. Selected print fields appear as a dotted rectangle with sizing
handles on each side and corner.
Pressing the TAB key moves the selection to the next field in the label and pressing SHIFT-
TAB moves the selection to the previous field.
Clicking on overlapping fields always selects the top-most field. Pressing the space bar
successively changes the selection to the fields underneath the point used to select the top
field.

Insert a New Print Field
The insert buttons located on the left of the Label Edit window set the Label Edit window to
insert mode. Select the button corresponding to the type of print field you wish to insert, then
drag the mouse on the label to specify where to place the new field.
You can also insert a new print field using the Insert Menu.

Edit Print Field Properties
You can open an Edit Properties dialog for a print field by the following methods.
•  Double click on a print field
•  Select the print field and press Enter
•  Select the print field and select Edit Properties from the Edit menu)

Edit Label Properties
You can open a Label Properties dialog for the label by the following methods.
•  Double click on a point on the label that does not contain a print field
•  Press Enter when no print field is selected.
•  Select Edit Properties from the Edit menu when no print field is selected.

Move or Resize a Print Field
Select a print field, then drag the entire field (to move the field) or drag a corner or side (to
resize the field). You cannot move a field outside the label or resize the field to less than its
minimum size.
A snap-to-grid function is available and can be set on or off using the Grid command in the
View menu.
The Size to Fit command in the Edit menu resets the selected print field to its standard size.

NOTE: In the FDP-5010 and Astra versions of the Label Editor, some field types (including
numeric fields) cannot be resized. This is because the fields have a position but no
size properties. Instead, the size is determined in the scale when the label is printed
(based on the number of digits, etc.).

Delete a Print Field
Select a print field, then select Delete from the Edit menu to delete the field.
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Transmit Label to the Scales
Select Transmit Label from the Tools menu to transmit the label in the currently active Label
Edit window to the scales. See Sending and Receiving Labels from the Scales for further
details.

Set the Grid and Zoom Options
You can enlarge or reduce the label display by setting the zoom ratio using the Zoom
command in the View menu.
You can specify whether or not to display a grid and set the snap-to-grid function on or off
using the Grid command in the View menu.
NOTE:  It is strongly recommended that you turn off snap-to-grid when editing existing labels,
especially those downloaded from the scales. This is because, if you hold down the mouse
button too long when clicking on a field, the click may be interpreted as a drag operation,
causing the field to move to the nearest grid point.

Auto-Size a Print Field (Size to Fit)
Select a print field, then select Size to Fit from the Edit menu to reset the field to its standard
size (if it has one).
The Label Editor also has an auto-size function. If you set auto-size ON for a field(in the Edit
Properties dialog), the field is automatically reset to its standard size whenever you change a
property (such as the number of digits) that affects the size.

Disable and Re-Enable Fields
Disabling a field inhibits the field from being printed on the label without deleting the field from
the label. Disabled fields can be re-enabled by the procedure described below.
In general, you should not need to use this feature other than to delete unused fields. The
feature is provided for backward-compatibility with Ishida label formats.

To disable a field, select the print field, then select Disable Field from the Edit menu.

To edit the disabled fields, select Edit Disabled Fields from the Edit menu. A dialog appears
listing the currently disabled fields. (The Edit Disabled Fields command appears dimmed if
there are no disabled fields in the label.) You can delete and edit (re-enable) fields using the
dialog.

Sub-Labels

A single Ishida label format can be used to define more than one label. In Label Editor, these
are called sub-labels. The fields for each sub-label are defined in the same label format and
the scale selects the correct fields to print based on the type of label being printed.

Unfortunately, this can result in many overlapping fields when the format is displayed in the
Label Editor, making the label format difficult to edit. To solve this problem, you can
selectively display only those fields that belong to a specified sub-label. The Edit Properties
dialog defines the sub-labels to which a field belongs. Use the Sub-Labels command in the
View menu (or the buttons at the righthand end of the toolbar) to select which sub-label to
display.
NOTE:  The sub-label settings for a label format are only stored in Label Editor. The settings
are set to default values when a label format is received from the scales (all fields assigned to
all sub-labels).
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5. Sending and Receiving Labels from the Scales
This section describes how to load label formats from the scales and how to send new label
formats to the scales.

The operation depends on the type of scale you are using:

AC-3000

Differences Between Label Editor and Scales Data Formats
The Label Editor program stores label data differently to the scales. Consequently some data
is lost if you transmit a label to the scales and then read it back again.
See Some Background on Ishida Label Formats for details.

Scales Communications Link
Label Editor connects to the scales using a serial port on the PC. Use the Comms Setup
command in the Setup menu to select the serial port to use and to set the communication
parameters (baud rate, etc.).

Loading Existing Label Data from the Scales
You can load the existing labels stored on the scales. This not only has the advantage of
providing you with a set of example labels to work from, but also enables you to obtain the
address and other scale-specific parameters set in the Label Properties dialog.

The procedure for loading label data from the scales is as follows.

1. Select Receive File from the Tools menu to prepare Label Editor to receive data.

2. A Save As dialog box appears. Specify the file in which to receive the data.

3. A Comms Progress dialog box appears to display the status of the data transfer. Wait for
the dialog box to appear, then initiate data transfer from the scales.

4. A message appears to notify you when the data transfer has completed.

5. If the received data contained label formats, a dialog opens asking whether you wish to
open the received data in a label data file. Click Yes if you wish to open the file. This
opens a new Label List window containing the label formats received from the scales.

Note that, even if you do not open the file at this time, you can import the received data
file at a later time using the Import Labels command.

Transmitting Label Data to the Scales
The procedure for sending label format data to the scales is as follows.

1. Make the Label Edit window for the label you wish to transmit the active window, or select
the label in the Label List window.

2. Select Transmit Label from the Tools menu.

3. Wait for the Comms Progress dialog box to appear, then initiate data transfer from the
scales.

4. A message box appears to notify you when transmission of the label data has completed.

Transmitting a File to the Scales
Binary-format files received by the Receive File command can be transmitted back to the
scales is as follows.

1. Select Transmit File from the Tools menu.

2. A File Open dialog appears. Select the file to transmit and click OK.

3. Wait for the Comms Progress dialog box to appear, then initiate data transfer from the
scales.

4. A message box appears to notify you when transmission has completed.
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FDP-5010

Differences Between Label Editor and Scales Data Formats
The Label Editor program stores label data differently to the scales. Consequently some data
is lost if you transmit a label to the scales and then read it back again.
See Some Background on Ishida Label Formats for details.

Scales Communications Link
Label Editor connects to the scales using a serial port on the PC. Use the Comms Setup
command in the Setup menu to select the serial port to use and to set the communication
parameters (baud rate, etc.).

Sending and Receiving Label Data to and from the Scales
You can load the existing labels stored on the scales. This not only has the advantage of
providing you with a set of example labels to work from, but also enables you to obtain the
address and other scale-specific parameters set in the Label Properties dialog.

The procedure for loading label data from the scales is as follows.

1. Select Communicate with Scales from the Tools menu. A dialog opens asking whether
you wish to save the currently open label file in IF21 format. You must save the file if you
wish to send it to the scales. If you click "Yes", a File Open dialog appears for you to
specify the file name.
You must save the file in the scales data directory selected in step 2 below and the file
name must be a valid name expected by the scales - typically FOMT.001, where "001"
specifies the IF21 file number and can be any three-digit numeric value.

2. A dialog appears for you to specify the directory containing the scales data. The Data
Save (IF21) communications function on the scales was initially intended for use with a
dedicated floppy disk backup unit (called an IF21FD). When communicating with a PC,
this directory fills the role of the floppy disk on the IF21FD.

3. A Comms Progress dialog box appears to display the status of the data transfer. Wait for
the dialog box to appear, then initiate data transfer from the scales.

4. When you have finished the data transfer, click the Close button in the progress dialog to
end the communications session.

5. If the received data contained label formats, a dialog opens asking whether you wish to
open the received data in a label data file. Click Yes if you wish to open the file. This
opens a new Label List window containing the label formats received from the scales.

Note that, even if you do not open the file at this time, you can import the received data
file at a later time using the Import Labels command.
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Astra

Differences Between Label Editor and Scales Data Formats
The Label Editor program stores label data differently to the scales. Consequently some data
is lost if you transmit a label to the scales and then read it back again.
See Some Background on Ishida Label Formats for details.

Scales Communications Link
Label Editor connects to the scales using a serial port on the PC. Use the Comms Setup
command in the Setup menu to select the serial port to use and to set the communication
parameters (baud rate, etc.).

Receiving Label Data from the Scales
You can load the existing labels stored on the scales. This has the advantage of providing
you with a set of example labels to work from.

The procedure for loading label data from the scales is as follows.

1. Select Receive from Scales from the Tools menu.

2. A dialog opens with instructions on how to initiate data transfer from the scale.
Follow the instructions to start the transfer.

3. Once data transfer starts, the dialog displays a running total of the number of records
received.

4. When data transfer is complete, a new dialog opens asking you what to do with the
received data. The right side of the dialog lists the number of records received for each
type of Astra data.
If you selected "All Data" when you initiated data transfer from the Astra, the Label Editor
will have received a full set of Astra data. This can be saved to provide a backup of the
Astra settings. The resulting database file can also be edited using the AstraLink
program.

5. Select the desired option. If you select "load into current database", you must also
specify whether you wish to overwrite any existing data with the same label number.

6. Click OK to load the data into the Label Editor.

Sending Label Data to the Scales
You can select whether to send a single label only, all labels in the database, or all data in
the database. The latter option is useful if you wish to use the Label Editor to restore the
scale settings that have previously been backed up from the scale using the procedure
described above in Receiving Label Data from the Scales.

1. To send a single label to the scale, make the Label Edit window for the label you wish to
transmit the active window, or select the label in the Label List window - then select Send
to Scales -> Current Label Only from the Tools menu.

2. To send all labels or the entire database, make the Label List window for the database
you wish to send the active window, then select Send to Scales -> All Labels in
Database or Send to Scales -> All Data in Database from the Tools menu.

3. A dialog opens with instructions on how to initiate data transfer from the scale.
Follow the instructions to start the transfer.

4. A message box appears to notify you when transmission of the label data has completed.
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6. Initiating Data Transfer at the Scales
The following describes the procedure for initiating data transfer at the scales for an AC-3000
series scale. The procedure is different for different scales models. Refer to the Ishida
documentation for the correct procedure for the scales you are using.

1. Set the scales to TEST mode.
2. Select DATA SAVE/LOAD (99).
3. Select TRANSFER FILE (2).
4. Enter the IF21 FILE NO.

If receiving label data from the scales
5. Select SEND, LABEL FORMAT (4).
6. Press the PRINT button.
7. The scales display indicates when data transfer has completed.

If transmitting a label to the scales
5. Select RECEIVE, LABEL FORMAT (4).
6. To set the new label in a slot other than slot 0, enter the slot number (but do

not press enter).
7. Press the PRINT button.
8. The scales display indicates when data transfer has completed.
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7. Setting Up the Label Editor
This section describes how to set the various setup data required by the Label Editor. The
setup data consists of all the data set from the Setup Menu.
WARNING:  The scales setup data must match the scale's requirements exactly. Only use the

data provided with Label Editor or any subsequent updates provided by Ishida.
If changes are required, the changes should only be made by someone with a
thorough understanding of how the label format data is used in the scales.
You may, however, safely change the "Name" assigned to unit properties,
property values, unit types, and print IDs (for example, if you wish to set names
for a language other than English).

WARNING:  A label data file saved for a particular setup will not work correctly if loaded when
the setup is different. The Label Editor checks the validity of label data files on
opening and displays error messages if the contents do not match the setup.

7.1 Overview

Scales Setup
The items in the Scales Setup sub-menu define the data structure and meaning of the label
format data required by the scales. As described in the warning note above, changing this
data should be done with extreme caution as labels will not print correctly if the setup does
not match the scale.

Unit Properties
These define the data values used by a unit type definition. Each unit property definition
consists of a name, a maximum, minimum and default value, and an optional set of allowed
values. If no set of allowed values is defined, the property can be set to any value within
the allowed range.
Unit property definitions can be viewed or edited using the Unit Properties command in the
Setup menu.
The unit properties for an actual print field are edited using the Edit Properties dialog.
See 7.2 Unit Properties for a detailed explanation.

Unit Types
An 8-bit value that defines the type (numeric, bar code, etc.) of field to print on the label. In
the Label Editor, the unit type defines which properties are to be set for the field.
The definition includes a "type" parameter which specifies how Label Editor displays print
fields that have that unit type.
See 7.3 Unit Types for a detailed explanation.

Print IDs
An 8-bit value that defines the field to print on the label (product name field, best by date,
etc.). Each print ID is assigned a unit type and some print IDs (such as the product name)
have a special meaning in the Label Editor.
See 7.4 Print IDs for a detailed explanation.

General Parameters
The General Parameters command in the Setup menu sets a range of parameters for the
Label Editor. All parameters other than the default label size must match the specifications of
the scales. If not, the scales may not operate correctly. Typically these parameters should
only need to be changed if Ishida changes the specifications of the scales equipment.

Comms Setup
The Comms Setup command in the Setup menu sets the serial port and communications
parameters for the communication link to the scales.
Make sure that the settings match the communications parameters used by the scales and
that the cable to the scales is plugged into the specified serial port.



15

Saving and Loading Setup Data
The Label Editor saves the current setup when it exits and reloads this setup when next
started.
However, you can save the current setup to a file using the Save Setup command and
reload a previously saved setup using the Load Setup command.
This function is useful if you are creating labels for two or more different types of scales which
have different setups.

Load Text Table
Astra only. Loads the text corresponding to each text table ID from a text file.

7.2 Unit Properties

Clicking on Unit Properties in the Scales Setup sub-menu of the Setup menu opens a
dialog for defining the unit properties used by the various print field unit types.

Unit Properties Dialog

The dialog displays a list of the currently defined unit properties. The following operations are
available.

Add a new unit property
Click the Add button.
This opens a Unit Property Definition dialog for you to define the new unit property.

Edit an existing unit property
Select a unit property from the list and click the Edit button (or double click on the unit
property).
This opens a Unit Property Definition dialog for you to edit the unit property.

Delete a unit property
Select a unit property from the list and click the Delete button.
This deletes the unit property from the list.

Click OK to save your changes or click Cancel to close the dialog without saving.

Unit Property Definition Dialog

Defines the following data for a unit property.
Name
Used to identify the property in the Edit Properties dialog.

Property Type
Some property types have specific meanings in the Label Editor. For example, the font size
property defines the size of the font used to display a print field in the Label Edit window
and is used to calculate the minimum size for the field.
Property types include user-defined property types which can be used to add new unit
properties in the future and filler properties which can be specified in unused areas of the
label data format.

Minimum
Minimum value for the property. Only applicable if the allowed property values list is blank.

Maximum
Maximum value for the property. Only applicable if the allowed property values list is blank.

Default Value
Default value for the property. The default value is set when a new print field is added to a
label. Only applicable if the allowed property values list is blank.
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Property Values
If the property can only take a number of pre-defined values, define those values in the
Property Values list. The following operations are available.

Add a new property value
Click the Add button.
This opens a Set Property Value dialog for you to define the new property value.

Edit an existing property value
Select a property value from the list and click the Edit button (or double click on the
property value).
This opens an Set Property Value dialog for you to edit the property value.

Delete a property value
Select a property value from the list and click the Delete button.
This deletes the property value from the list.

Set Default
Select a property value from the list and click the Set Default button.
This marks the selected property value as the default. The default value is set when a new
print field is added to a label. An asterisk (*) indicates the current default value in the list.

Load the property values from a file
Loads the property values from a scales EPROM file or a text file. Only available for
properties with the Image ID or Text Table ID property type.
This function is useful for ensuring that the label displayed in the Label Edit window
matches the label printed on the scales.
Clicking the Load from File button opens a File Open dialog for you to specify the EPROM
file or text file. Select the file then click OK. This loads the values from the file, overwriting
the previous property values.

Click OK to save your changes or click Cancel to close the dialog without saving.

Set Property Value Dialog

The form of this dialog depends on the property type.

All versions of the dialog contain the following fields.

Name
Assigns a name to the property value for use in the Label Editor.
For properties with the "Text Table ID" or "Units" type, the name specifies the actual text to
be displayed for the property.

Value
Specifies the value of the property (the value sent to the scales). The allowed range is 0 to
255 (i.e. an 8-bit value).

Other versions of the dialog assign specific meanings to a property value so that the Label
Editor knows how to interpret the property when displaying a field in the Label Edit window.

Click OK to save your changes or click Cancel to close the dialog without saving.
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7.3 Unit Types

Clicking on Unit Types in the Scales Setup sub-menu of the Setup menu opens a dialog for
defining the unit properties used by the various print field unit types.

Unit Types Dialog

The dialog displays a list of the currently defined unit types. The following operations are
available.

Add a new unit type
Click the Add button.
This opens a Unit Type Definition dialog for you to define the new unit type.

Edit an existing unit type
Select a unit type from the list and click the Edit button (or double click on the unit type).
This opens a Unit Type Definition dialog for you to edit the unit type.

Delete a unit type
Select a unit type from the list and click the Delete button.
This deletes the unit type from the list.

Click OK to save your changes or click Cancel to close the dialog without saving.

Unit Type Definition Dialog

Defines the following data for a unit type.

Name
Assigns a name to the unit type. Used in Label Editor only.

Type
Specifies the type of the unit type. The type determines how the Label Edit window
displays print fields with this unit type. For example, a print field with a "Bar Code" unit type
appears as a bar code.
In addition to the standard unit types, a "User-Defined" type is also provided to allow new
unit types to be defined in the future.

Code
Specifies the unit type code that is transmitted to the scales.

Properties Used and Available Properties
The list on the left shows the properties that are set in the data packet that is transmitted to
the scales for print fields with this unit type. The properties are listed in the order that they
appear in the data packet. The list on the right shows the available properties.
Use the Add and Delete buttons to add or remove properties from the Properties Used list
on the left.

Note: The order in which the properties appear in the list defines the data structure of the
packet. It is important that you specify the properties in the correct order expected by
the scales.

Click OK to save your changes or click Cancel to close the dialog without saving.
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7.4 Print IDs

Clicking on Print IDs in the Scales Setup sub-menu of the Setup menu opens a dialog for
defining the print IDs used in labels.

Print IDs Dialog

The dialog displays a list of the currently defined print IDs. The following operations are
available.

Add a new print ID
Click the Add button.
This opens a Print ID Definition dialog for you to define the new print ID.

Edit an existing print ID
Select a print ID from the list and click the Edit button (or double click on the unit type).
This opens a Print ID Definition dialog for you to edit the print ID.

Delete a unit type
Select a print ID from the list and click the Delete button.
This deletes the print ID from the list.

Click OK to save your changes or click Cancel to close the dialog without saving.

Print ID Definition Dialog

Defines the following data for a print ID.

Name
Assigns a name to the print ID. Used in Label Editor only.

Short Name
Assigns a name to the print ID. The Edit Label window uses the short name to display print
fields that are displayed by name (for example, print fields with the Variable-Length Text
unit type).

Code
Specifies the print ID code that is transmitted to the scales.

Special Meaning
Some print IDs have a special meaning in the label format and are handled differently to
other print IDs when transmitted to the scales. See 8. Some Background on Ishida Label
Formats for a full explanation.

Unit Type
Specifies the unit type of the print ID. The unit type determines how a print field with this
print ID appears on the label and the structure of the data transmitted to the scales. Unit
types are defined in the Unit Type dialog (see 7.2 Unit Types).

Click OK to save your changes or click Cancel to close the dialog without saving.
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7.5 General Parameters

Clicking on General Parameters in the Setup menu opens a dialog to set various parameters
used in the Label Editor.

The following items can be set.

Note: Some of the following fields may not appear, depending on which version (AC-3000,
Astra, etc.) of the Label Editor you are using.

Min Label Number
Used on the Astra version to specify the minimum label number. Typically 10 (international)
or 20 (USA).

Scale Type
Used on the Astra to specify which Astra model (country) is being used.

Logo Area Offset
The offset address of the logo data area in the EPROM. Required if you wish to load logo
data from an EPROM file (see the Load from File command in the Unit Property Definition
dialog for details).

Logo Area Size
Specify the size of the logo data area in the EPROM.

EPROM #2 Start Address
Specify the start address of the #2 EPROM (the EPROM containing the label format and
logo data).

Label Area Offset
The offset address of the label data area in the EPROM. Required if you wish to save label
data in an EPROM file.

Label Area Size
Specify the size of the label data area in the EPROM.

Text Area Offset
The offset address of the standard text data area in the EPROM. Required if you wish to
load Text Table ID data from an EPROM file (see the Load from File command in the Unit
Property Definition dialog for details).

Maximum Number of Labels
Specify the maximum number of labels that can be stored on the scales. This determines
the number of label slots that appear in Label List windows.

Maximum Units per Label
Specify the maximum number of print fields per label. This number defines the size of the
label format data transmitted to the scales (unused print field data is set to zero).

Data Packet Size
Specifies the size (in bytes) of the data for each print field transmitted to the scales. The
data packet is padded with zeros up to the specified packet size.

Reverse Feed Printer
In order to feed the label being printed far enough out of the label printer for you to remove
it, standard Ishida label printers must print the first few millimeters of the following label. This
section at the bottom of the label is called the Òpreprint sectionÓ. The Label Editor contains
special processing to deal with the preprint section (See 8. Some Background on Ishida
Label Formats for further details).
However, future printers may incorporate a reverse feed function removing the need for
preprinting the bottom of the label. In this case, select the Reverse Feed Printer check box
to disable the preprint processing in the Label Editor.

Preprint Length
If not using a reverse feed printer, specify the length of the preprint section.

Inter-Label Spacing
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Specify the gap between labels.

Logo Type
Specify the format of the logo bitmap (row scan or column scan). At the time of writing,
Ishida scales only support column scan bitmaps.

Maximum Label Size
Specifies the maximum size of a label.

Default Label Size
Specifies the default size of a label. Labels are initially set to the size when you create a
new label.

Printer Dots/mm
Specifies the label printer resolution. Only used internally by Label Editor to display the
equivalent value in mm for parameters specified in dots.
In the FDP-5010 and Astra, this value is the data dot size (the unit of length used in the
label format data) and is not the same as the actual printer dot size.

Click OK to save your changes or click Cancel to close the dialog without saving.
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8. Some Background on Ishida Label Formats
This section describes background information on how Ishida labels are defined.

Structure of Label Format Data
The data for a label format consists of a header section (primarily the data set in the Label
Properties dialog) and a series of data blocks containing the data for each print field. The
print field data items are called properties. In the Label Editor, they are the values set in the
Edit Properties dialog.
To allow for future modifications to the way label formats are stored in the scales, the data
structure of the print field data blocks are defined in the Label Editor setup data and can be
modified by the user. (However, the setup must match the data structure expected by the
scales. Do not modify the setup data unless you have a thorough understanding of the
requirements of the scales. Obtain any necessary upgrades from Ishida.)

Print ID and Unit Type
Print fields have two special properties: the print ID and unit type. The print ID is a code that
defines the type of field (whether the field is a price, product name, or bar code, etc.). Each
print ID code has an associated unit type which defines how the field is printed (whether the
field is numeric, variable-length text, or a bar code, etc.). The unit type also determines the
data structure for the print field's properties.
The definitions of the unit properties, unit types, and print IDs are collectively called the
scales setup. How to set these in Label Editor is described in more detail in 7. Setting Up the
Label Editor.

Print Field Properties
The Label Editor setup not only defines the properties used to specify a print field but also
defines the meaning of those properties. This allows the Label Edit window to display the
print field as it would appear on the label. For example, if the orientation property of a print
field specifies rotation of the field by 90 degrees, the Label Edit window recognizes that
property and displays the field accordingly.

Preprint Section
Ishida label printers print the first few millimeters of the following label at the same time as
printing the preceding label. This is done so as to feed the preceding label out of the printer
far enough for it to be removed. The section at the bottom of the label is called the preprint
section.
To achieve this, the Label Editor moves the label format data for the preprint section to the
top of the label when transmitting the label to the scales. Similarly, the Label Editor moves
the preprint section back to the bottom of the label when loading a label from the scales.
As the preprint section is printed before the rest of the label (i.e. before the scale knows what
PLU will be printed), it may only contain the store name and address.

Store Name and Address Field
The store name and address field is a mandatory field in Ishida label formats and must be
located in the preprint section described above. Consequently, the store name and address
field cannot be moved or deleted in the Label Editor.

Product Name Field
The product name field has a special meaning in Ishida labels. The product name field can
be specified as either ÒfixedÓ or ÒvariableÓ in the Product Name Area setting in the Label
Properties dialog. If ÒvariableÓ is specified, the product name field is treated the same as other
fields and no special considerations apply. However, if ÒfixedÓ is specified, the product name
area differs from other fields in the following ways.

•  In the scales, the height of the product name field is taken from a parameter set in the
scales rather than from the label format. The field height set in the Label Editor is used
for display only and the Label Editor sets the product name height to zero when



22

transmitting a label to the scales.

•  In ÒfixedÓ mode, the label format downloaded from the scales does not contain the height
of the product name field (because the height field is set to zero). In this case, the Label
Editor resets the height to a default value.
However, if the downloaded height is non-zero, the Label Editor sets the product name
area mode to ÒvariableÓ and uses the downloaded height unchanged.

•  As the height of the product name field can only be set to multiples of 19 dots in the
scales, the same restriction is applied to the field height in the Label Editor.

•  Other fields should not be located in the product name area. Specifically, the Y
coordinate of a field must be not be between the top and bottom of the product name
field. This is because the product name height is reset to zero when transmitted to the
scales.
Although the Label Editor allows you to place fields in such a position, the fields are
forcibly moved outside the product name area when the label is transmitted to the
scales.

Label Height
The label height value stored in the scales does not include the height of the preprint and
product name areas (unless the product name area is set to ÒvariableÓ mode). When loading
a label from the scales, the Label Editor recalculates the label height by adding these heights
back to the received height value. However, for the reason described above, the height of
the product name field is set to a default value. Consequently the recalculated label height
will be different to the value when the label was transmitted to the scales.
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9. Editing Crowded Labels
Ishida label formats downloaded from the scales can be quite cluttered with many
overlapping fields. This makes them difficult to edit. The following are some tips to make
editing such labels easier.

Use the Sub-Label Function
The reason that the downloaded labels are so cluttered is that a single format definition on
the scales often contains a number of overlapping labels. The scales selects which fields to
print depending on the type of label being printed.
To achieve the same effect in the Label Editor, you can assign fields to sub-labels (in the Edit
Properties dialog). You can then select to only display the fields belonging to a specified sub-
label.

Use the Space Bar to Select Overlapping Fields
Clicking on overlapping fields always selects the topmost field. Pressing the space bar
successively changes the selection to the fields underneath the point used to select the
topmost field.

Turn Off Snap-To-Grid
Holding down the mouse button too long when clicking on a field may cause the click to be
interpreted as a drag operation. If snap-to-grid is on, this causes the field unintentionally to
move to the nearest grid point.

Delete Disabled Fields
Ishida labels often already have the maximum number of fields defined. If you wish to add
any additional fields of your own, you must first delete some existing fields. Fortunately,
Ishida labels also often contain a number of disabled fields. These are fields that are
contained in the label format but which are not printed on the label. Use the Edit Disabled
Fields command in the Edit menu to delete such fields.


